Jan 29, 2018

AMD GPU Driver Requirements for Elgato 4K Capture Utility

Starting with Elgato 4K Capture Utility 1.0.3, older drivers for AMD GPUs will not work with Elgato 4K Capture Utility.

The new  driver requirements are:  
    •    Crimson ReLive Edition 17.10.2 (or newer)

For example:
    •    Adrenalin Edition 18.1.1 driver will work
    •    Adrenalin Edition 17.12.2 driver will work
    •    Crimson ReLive Edition 17.10.1 driver will NOT work

AMD GPU drivers can be downloaded at http://support.amd.com/en-us/download

The AMD GPU requirements are unchanged and are:
    •    Radeon RX Vega (or better)